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Intro:

WHAT EXACTLY IS LOGIC?

Logic is a MIDI data manipulator, which allows almost total control of any sort of MIDI data using arithmetic and/or Boolean expressions. The most obvious part of Logic is the sequencer, but MIDI data can also be processed outside of it; in the Environment.

HOW DOES THE ENVIRONMENT WORK?

The environment is shown as pages known as Layers. Layers contain Objects, which can be used to direct MIDI data to the sequencer, direct MIDI data to a particular internal or connected sound source. Other examples are to create a mixer, delay or arpeggiate a note, or to control parameters in a sound module. Once an object is on an environment layer, MIDI data from any specified track can be sent to it.

HOW DO I… 

Navigate Between Windows?

Logic allows multiple instances of the same window so to reselect a hidden window choose it from the bottom of the Windows menu.
Toggle between windows?
Apple-~ (tilde). 

Note: this does not include the Event list or Transform windows, which are always floating.
TOOLS

Select the second tool?

Hold down the Apple key

Note: the active tool can also be selected by pressing ESC, then pressing the key for the wanted tool (eg 3 for the Zoom tool in the Sample Editor).

Reset a control to the default value?

Option-click

A.   MIDI

ARRANGE WINDOW

HOW DO I…

Show / hide the Media tabs?

Press the B key

Show / hide the Lists tabs?

Press the T (Tempo), or E (Event) key

Record Enable a Track?

Click on the wanted track in the track list (which is just to the left of the bars).

Return to Zero?

Double click on the Stop button.

Click the leftmost transport button.

Play (or Record) from a certain location?

Click at the desired location in the bottom of the bar ruler.

Setup for a Punch-in?

1. Enable AutoPunch and Replace on the Transport Bar

2. Adjust the Pre-Roll/ Post-Roll, and Punch-in points on the Timeline
Option-click in the Timeline and adjust by dragging the punch-in /out points (red), and pre-roll /post-roll (green).

Option-click again to delete the punch-in zone.

Hear a Click Track?

Click on the metronome button in the Transport window.

Adjust the Metronome Settings?

Control-click on the metronome button.

Select a Sound Source for a Track?

Select the sound from the library

Click on Setting on the channel strip and select the sound

Select a specific MIDI channel?

Click and drag on the number beside Channel in the Track Parameter Box.

Select a specific sound (Program) for MIDI?

Click on the Program select box in the Track Parameter Box (actually the “Instrument” box). Now click to the far right of the box and select from the pop up menu.

Select the sound, deselect the Programme box, enter record, and click the box at the required location.

Select the region and use the Hyper edit window (use the pencil tool).

Use the Event List Editor – [select the bar in the Arrange window], use the pencil tool and click on the Create button. Click on Progr. Change to create the programme. Double click on Position to adjust the location.

Delete a Program change?

Use either the Hyper Edit window or the Event List window.

Select a specific sound (Program) for a Virtual Instrument?

1. Click on the channel I/O input and select the instrument

2. Select (or create) the wanted sound from the instrument

Create a second track on the same channel?

Click on the ‘New Track with Duplicate Setting’ button (above the track headers)

Rearrange the order of tracks?

Click on the track icon and drag it up or down as required in the track list.

Make one track higher or shorter?

Click on the extreme lower left of the track and select a height from the pop-up menu.

Select Auto Zoom from the Toolbar to make the active track always zoomed.

TIME SIGNATURES & TEMPO

Set the Tempo?

Double click on the tempo in the Transport Window.

Adjust the Tempo over time?

1. Open Global Tracks & the Tempo bar

2. Use the Pencil Tool to write a new target tempo

3. Use the Pointer Tool to adjust the tempo

4. Drag the Tempo Curve Node (blue) to produce accel. or decel.

Options Menu>Tempo Operations…
Enter a new Time Signature for part of a song?

1. Open Global Tracks
2. Use the Pencil Tool and click on the Time Sig. bar
Time Compress / Expand a MIDI region?

Option-drag the end of the region

Import a tempo map?

Use File>Open (note: drag & drop, or Import will not work)

Rename a Track?

Select Create Track Name from the Track sub-menu.

Rename a Channel / Instrument?

Click on the name at the top of the Track Parameter Box and type the new name.
Apple-double click on the track name.

Rename a track Region?

Select the region. Click on the name at the top of the Region Parameter Box and type the new name.

Set a Loop (Cycle) duration?

Click and drag (L -> R) in the top half of the Marquee Stripe.

Solo a part?

Select the Solo Tool and click and hold on the region wanted.

Select the Solo button in the transport window. Click on the region wanted (Shift-click to select multiple regions). Soloed regions have a yellow border.

Loop a Region?

Press the L key to loop out to the end of the song.

Click and drag on the top-right of the region to make any desired loop-length.

MARKERS

Enter a Marker at a specific location?

Open Global Tracks and click on the Marker bar with the Pencil Tool.
Click in the bottom half of the bar ruler while holding Apple-Option.

Place the Playhead, then press Control-K.
Move a Marker?

Click and drag the Marker while holding the Apple key.

Rename a Marker?

Double click on the Marker while holding the Apple-Control.

Play from a Marker?

Double click on the Marker while holding the Apple key.

Delete a Marker?

Drag it off the bar ruler.

Note: Markers can also be created / edited in the Lists (Marker tab)

Create a Marker ‘on the fly’?

Control-K
Create a Jump Section?

Click and drag (R -> L) in the Marquee Stripe

1. create a loop section

2. press the J key

Control-click in the Marquee Stripe (Timeline) and select ‘swap left and right locator’
Transpose a Track?

Click on the Transpose field (right side for octaves) of the Track Parameter Box.

Create an Empty MIDI Region?

Control-click on the track and position you want a new region.

TRACK AUTOMATION

Draw automation data?

Use the Pointer Tool and click to make a node. 
To delete a node: click on it. 
Nodes or lines can be dragged into position.
Use the Pencil Tool to draw freehand.

Draw curves?

Use the Automation Curve Tool

Select automation data (eg for dragging)?
Use the Automation Select Tool

Copy automation data within the track?

Option-drag

Copy track automation (eg Volume) to another track(s)?

Group all tracks to have the same automation. Tick ‘automation mode’ in the group settings. Select Write on one of the grouped tracks, and record the required fade.

Note: automation can be copied (option-drag) with any region.

Delete all the automation for a track?

Options>Track Automation>Delete… (choose one)

Convert Hyperdraw (region/ MIDI controller) automation to track automation?

Options>Track Automation>Move Current Region Data to Track Automation
View automation sub-tracks?

Click on the arrowhead of the main track header.

Option-click to view all automation sub-tracks.

What is the difference between Touch and Latch modes?

Touch updates the data and reverts to the pre-recorded data (like punch-in). Latch will continue to write the last value of the controller (more like punch in but no punch out).
Assign an external controller to a MIDI controller or Plug in parameter?

(using the Quick Access feature)

1)
Select the required parameter in the track header.

2)
Preferences>Automation. Click on Learn Message, move the controller, and click Done.

Note: the external controller will adjust whatever parameter is now active in Logic.

Convert Automation data?

1. Select the automation parameter to copy, or convert, in the Automation Parameter menu. 
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2. Command-click on the Automation Parameter menu and choose a destination 

parameter.
HYPER EDITOR

Select Events?

Shift-click

Move Events?

Select, then Shift-drag

Copy Events to another controller?

Option-drag

Convert Hyper Edit data (Event Definitions)?

Double-click on the controller name in the Hyper Editor

PIANO ROLL WINDOW

HOW DO I …

Open the Piano Roll Window?

Double click on the object in the Arrange Window.

Step input notes from the keyboard?

Select the IN button.

Change the duration of a note?

Click on either end and drag.

For multiple notes: Shift-click and drag; to set all selected notes to the same end time.



Option-Shift-click and drag; to set all selected note lengths the same.
Fine adjust the start position of a note?

Select the note, then press Control, then drag the note

For super-fine resolution hold Control-Shift.

Copy a note?

Option-click and drag on the note.

Paste a note without merging?

Choose Paste Replace from the edit sub-menu.

Quantize notes?

Select the notes. Click on the Q button and select the appropriate value from the pop-up menu.

Adjust the quantization amount?

Control-click in a blank area of the region parameter box. Set Q-Strength to desired %

Adjust a note’s velocity?

Select the V Tool and click and drag vertically over the note.

To adjust several notes to the same velocity: hold Option while scrolling the V tool vertically over one of the selected notes.

Adjust a range of velocities over notes?

Click the velocity box below the keyboard.

In the Piano Roll window sub-menu select View/Hyperdraw/Note Velocity.

Click and hold, then release to set the velocity start position. Click once more at the desired end velocity position.

Audition a note?

Click on the note.

Select all the notes available on one pitch?

Click on that pitch on the on-screen keyboard.

Select all the notes within a range of pitches?

Click and drag across the wanted note range on the on-screen keyboard.

Select all the notes within part of a region?

1) set the locator points to the desired region

2) Edit>Select inside Locators (SHIFT-I)

See all the parameters of a note?

Double click on the note. This will open the Event List with the note data highlighted.

Sub-menu View/Event Float will open an individual note parameter window.

Change the Grid value?

Double-click on the field below the Time Signature in the Transport Window

See Multiple MIDI Regions in the Piano Roll window?

Select the desired regions in the arrange window.

Notes: 1) to distinguish region MIDI data; colour the regions, and select View>Region Colours in the Piano Roll window. 

2) page 399 of the manual is wrong

MIXER WINDOW

Hide a Track in the Mix Window?

In the ARRANGE Window click on the H button above the track headers. Now select any tracks to be hidden with its track H button.

B.   AUDIO INSTRUMENTS & PLUG-INS

Select a particular Audio Instrument?

Click in the field below I/O.

Select a particular Sound?

1. Open the Track Mixer window and click on “Setting”

2. Select an Audio Instrument sound from the pop-up menu.

Sounds can also be selected directly from the Library.
Bypass a Plug-in on the channel?

Option-click

Move a plug-in (with settings)?

Apple-drag

Copy a plug-in?

Option-Apple-drag

Graphically edit a sample in the EXS24?

Control-click in the sample start or end field in the EXS24 editor.

C.   AUDIO

Import an audio file into a track?

1. Select the audio track

2. Select the audio file in the Browser and double-click on it

Audio can also be drag and dropped into a track.

Bounce the QTMI sounds along with any audio tracks?

Change the MIDI tracks to Instrument Tracks and select the DLS Music Device plugin.

Adjust audio to fit to the bars / beats?

Select the required number of bars

In the Arrange Window sub-menu: Audio/Adjust Region Length to Locators.

Option/ click and drag on the lower end of the region. Note: this doesn’t work on Apple Loops (CAF files).

Perform non-realtime editing (eg normalize)?

1. Double-click on the region to open the sample window.

2. Choose from the Function sub-menu.

Select part of a region in the Arrange Window?
Use the Marquee Tool (+)

Select and edit audio between transients?

1. Double-click on the region to open the sample window.

2. Enable the ‘Transient Editing Mode’ button ( < | > ) , beside the View menu.

3. Double-click to select audio between transients.

4. Cut, copy etc

Notes: you can drag a transient marker to move it, and the - & + buttons decrease / increase the number of transients.

Nudge audio regions?

First, Control-click on the Toolbar and add ‘Nudge Left/Right’ and ‘Nudge Value’ to the Toolbar.

Select the desired Nudge Value and click on the Nudge Left or Right icon.

Note: the nudge value is independent of the Snap value.
FADES

Fade or Crossfade audio?

Use the Fade Tool (and sweep across the end of the region).
Delete a Fade or Crossfade?

Option-click on the fade, using the Fade Tool

Adjust the Fade/ Crossfade Curve Shape

Drag (L-R) over the fade with the Fade Tool
Control-Shift, and drag the curve (L-R). 

Add Reverb to a mix?

1. In the Mixer Window, select a Bus from the Send box of the desired channel.

(this will automatically create an Aux Channel)

2. Plug in the desired Reverb on the Aux Channel

3. Repeat step 1 for all channels to go to the reverb

4. Set channel reverb levels with the small rotary fader beside the bus send.

Note: Aux channels can also be created by using the + button at the left side of the mix window, or from the Mix Window OPTIONS menu.

D.  SETUPS

Note:  Global setups: Logic Pro Menu>Preferences


Song setups: File Menu>Project Settings

TRANSPORT BAR

Control-click on a blank section of the transport bar (note: the Master Level slider will only show if there is enough screen space)

GLOBAL TRACKS

Control-click on the Global Tracks blank space

Option-G

TRACKS

To Reassign a Track Object: Control-click on the Track Header:

To Configure the Track Header: Control-click on the Track Header:

MIXER CHANNELS

Control-click on the channel blank space

REGION PARAMETER BOX

To set delay time in mS: Control-click

AUTOMATION

Control-click on the track when Automation View is on.

CAPS LOCK KEYBOARD

Caps Lock

TOOLBARS

To assign a third Tool (to the mouse Right-click):

Preferences>General>Editing- Right Mouse Button: is assignable to a tool

MARQUEE TOOL IN ARRANGE WINDOW

To have the mouse pointer automatically change to the Marquee Tool when scrolling onto the bottom half of a region:

Preferences>General>Editing>Pointer Tool in Arrange Provides: Marquee Tool Click Zones

Note: the Fade Tool can be similarly set.

CATCH MODE

The Blue Catch button (running man) is provided for each window that has a timeline. When enabled, that window will keep the curser (Song Position Line, SPL) in view. In other words the graphical playback of that window will sync to the active window. The default for Catch is on, and it cannot be turned off unless Preferences>General>Catch settings are deselected.

If it is enabled there is a choice of window scrolling for each window: View>Scroll in Play.

LINK

